Fix [dyld: Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib] error after upgrading openssl on OSX

Fix [dyld: Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib] error after upgrading openssl on OSX

On the weekend I played around with small data-sciency stuff on my laptop. It was just a small project, and I need to install something on my machine, it requires me to run a command to update my homebrew. But I accidentally run brew upgrade instead of brew update. That prior command turns out upgrade all of the homebrew formula and packages installed on my laptop to the latest version. At first I thought it was fine, until I encountered this error dyld: Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib, then it starts my frustration.

Read more
Your browser is out-of-date!

Update your browser to view this website correctly.&npsb;Update my browser now

×